VS:GetFillJAxisEndPoint: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the J-axis end point of the fill.

Note: only works with 2D objects that have a gradient or image fill.

PROCEDURE GetFillJAxisEndPoint(
objectHandle :HANDLE;
VAR xJAxisEndPoint :REAL;
VAR yJAxisEndPoint :REAL);
def vs.GetFillJAxisEndPoint(objectHandle):
    return (xJAxisEndPoint, yJAxisEndPoint)

Parameters

objectHandle HANDLE Handle to the object with fill.
xJAxisEndPoint REAL X coordinate of J-axis point.
yJAxisEndPoint REAL Y coordinate of J-axis point.

Example

VectorScript

GetFillJAxisEndPoint(objectHandle, xJAxis, yJAxis);

Python

xIAxis, yIAxis = vs.GetFillJAxisEndPoint(vs.FSActLayer())

Version

Availability: from VectorWorks10.0