VS:GetFillIAxisEndPoint

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the I-axis end point of the fill.

Note: only works with 2D objects that have a gradient or image fill.

PROCEDURE GetFillIAxisEndPoint(
objectHandle :HANDLE;
VAR xIAxisEndPoint :REAL;
VAR yIAxisEndPoint :REAL);
def vs.GetFillIAxisEndPoint(objectHandle):
    return (xIAxisEndPoint, yIAxisEndPoint)

Parameters

objectHandle HANDLE Handle to the object with fill.
xIAxisEndPoint REAL X coordinate of I-axis point.
yIAxisEndPoint REAL Y coordinate of I-axis point.

Example

VectorScript

GetFillIAxisEndPoint(objectHandle, xIAxis, yIAxis);

Python

xIAxis, yIAxis = vs.GetFillIAxisEndPoint(vs.FSActLayer())

Version

Availability: from VectorWorks10.0