VS:GetFillFore: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
mNo edit summary
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Procedure GetFillFore returns the fill foreground color of the referenced object. RGB values are in the range of 0~65535.</desc>
Procedure GetFillFore returns the fill foreground color of the referenced object. RGB values are in the range of 0~65535.
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 53: Line 54:
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
redValue,greenValue,blueValue = vs.GetFillFore(vs.FSActLayer())
red_value, green_value, blue_value = vs.GetFillFore(vs.FSActLayer())
</code>
</code>
</sample>
</sample>

Revision as of 11:03, 14 October 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetFillFore returns the fill foreground color of the referenced object. RGB values are in the range of 0~65535.

PROCEDURE GetFillFore(
h :HANDLE;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetFillFore(h):
    return (red, green, blue)

Parameters

h HANDLE Handle to object.
red LONGINT Returns RGB color component value.
green LONGINT Returns RGB color component value.
blue LONGINT Returns RGB color component value.

Example

VectorScript

GetFillFore(handleToObject,redValue,greenValue,blueValue);

Python

red_value, green_value, blue_value = vs.GetFillFore(vs.FSActLayer())

Version

Availability: from MiniCAD6.0

See Also

VS Functions:

VS:RGBToColorIndex | VS:ColorIndexToRGB

VS Functions:

[[VS:RGBToColorIndex]]

| [[VS:ColorIndexToRGB]]