VS:GetFileN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(remark about mask format)
Line 54: Line 54:


[[VCOM:VectorWorks:Filing:IFileChooserDialog::SetDefaultExtension]]
[[VCOM:VectorWorks:Filing:IFileChooserDialog::SetDefaultExtension]]
(MaKro, 2016.10.18):
:Mask format change in VW2016 on a Windows 7 machine
:Python mask example: '*.txt' if VW-Version < 2016 else 'txt'
</remark>
</remark>



Revision as of 13:15, 18 October 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the fully-qualified pathname of the selected file.

FUNCTION GetFileN(
title :STRING;
defaultFolder :STRING;
mask :STRING;
VAR fileName :STRING) : BOOLEAN;
def vs.GetFileN(title, defaultFolder, mask):
    return (BOOLEAN, fileName)

Parameters

title STRING
defaultFolder STRING
mask STRING
fileName STRING

Remarks

The GetFileN uses the SDK interface IFileChooserDialog

VCOM:Working with File/Folder Choose Dialogs

the ‘mask’ parameter goes as input to fileChooser->SetDefaultExtension(mask);

VCOM:VectorWorks:Filing:IFileChooserDialog::SetDefaultExtension

(MaKro, 2016.10.18):

Mask format change in VW2016 on a Windows 7 machine
Python mask example: '*.txt' if VW-Version < 2016 else 'txt'

Version

Availability: from Vectorworks 2014