VS:GetFile: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fixed broken example)
No edit summary
 
Line 62: Line 62:
<code lang="py">
<code lang="py">
def Example():
def Example():
vs.GetFile(fileName)
fileName = vs.GetFile()
if not vs.DidCancel():
if not vs.DidCancel():
vs.Read(a,b,c)
vs.Read(a,b,c)

Latest revision as of 08:47, 24 January 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetFile displays a standard file dialog which requests the user to select a text document.

It is advisable to call DidCancel after using this procedure and check that the user did not cancel the file selection process.

PROCEDURE GetFile(
VAR fileName :STRING);
def vs.GetFile():
    return fileName

Parameters

fileName STRING Returns name of selected file.

Remarks

At least on the Mac, fileName does not set the default folder to browse. Use GetFileN if you want this functionality.

Example

VectorScript

PROCEDURE Example;
VAR
	fileName : STRING;
	a,b,c : INTEGER;
BEGIN
	GetFile(fileName);
	IF NOT DidCancel THEN BEGIN
		Read(a, b, c);
		Close(fileName);
	END;
END;
RUN(Example);

Python

def Example():
	fileName = vs.GetFile()
	if not vs.DidCancel():
		vs.Read(a,b,c)
		vs.Close(fileName)


Example()

Version

Availability: from All Versions