VS:GetFPat

From Vectorworks Developer
Revision as of 17:02, 28 April 2008 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetFPat returns the fill pattern of the referenced object.

A positive value corresponds to the index of the fill pattern on the pattern palette. A negative value corresponds to internal index of a vector fill pattern applied to the object.

Fill patterns and their associated constants can be found in the VectorScript Appendix.

FUNCTION GetFPat(
h :HANDLE) : LONGINT;
def vs.GetFPat(h):
    return LONGINT

Parameters

h HANDLE Handle to object.

Remarks

The negative values need to be converted to positive values for Index2Name to work.

Example

VectorScript

FPatValue:=GetFPat(HandleToObj);

Python

FPatValue = vs.GetFPat(HandleToObj)

Version

Availability: from All Versions