VS:GetFPat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetFPat returns the fill pattern of the referenced object.

A positive value corresponds to the index of the fill pattern on the pattern palette. A negative value corresponds to internal index of a vector fill pattern applied to the object.

Fill patterns and their associated constants can be found in the VectorScript Appendix.

FUNCTION GetFPat(
h :HANDLE) : LONGINT;
def vs.GetFPat(h):
    return LONGINT

Parameters

h HANDLE Handle to object.

Remarks

The negative values need to be converted to positive values for Index2Name to work.

Example

VectorScript

FPatValue:=GetFPat(HandleToObj);

Python

FPatValue = vs.GetFPat(HandleToObj)

Version

Availability: from All Versions