VS:GetEvent

From Vectorworks Developer
Revision as of 07:46, 24 September 2019 by Ptr (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

See the <a href=http://www.vectorlab.info/index.php?title=Events>VectorLab article</a> on object events (this page is offline).

FUNCTION GetEvent( ) :LONGINT;
def vs.GetEvent():
    return LONGINT

Parameters

Remarks

[Ptr 09/23/2019]

CONST
  {Event ID's}
  kEventID_Reset = 3;
  kEventID_OnObjPref = 4;
  kEventID_OnInitProperties = 5;
  kEventID_OnDoubleClick = 7;
  kEventID_OnUIButtonHit = 35;
  kEventID_OnAddState = 44;
# Event ID's
kEventID_Reset = 3
kEventID_OnObjPref = 4
kEventID_OnInitProperties = 5
kEventID_OnDoubleClick = 7
kEventID_OnUIButtonHit = 35
kEventID_OnAddState = 44

Version

Availability: from All Versions

This is drop-in function.