VS:GetEvent: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix old link to vectorlab)
No edit summary
 
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
See *[[VS:Object Events]].
See [[VS:Object Events]].
</desc>
</desc>



Latest revision as of 17:53, 13 May 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

See VS:Object Events.

FUNCTION GetEvent( ) :LONGINT;
def vs.GetEvent():
    return LONGINT

Parameters

Remarks

[Ptr 09/23/2019]

CONST
  {Event ID's}
  kEventID_Reset = 3;
  kEventID_OnObjPref = 4;
  kEventID_OnInitProperties = 5;
  kEventID_OnDoubleClick = 7;
  kEventID_OnUIButtonHit = 35;
  kEventID_OnAddState = 44;
# Event ID's
kEventID_Reset = 3
kEventID_OnObjPref = 4
kEventID_OnInitProperties = 5
kEventID_OnDoubleClick = 7
kEventID_OnUIButtonHit = 35
kEventID_OnAddState = 44

Version

Availability: from All Versions

This is drop-in function.