VS:GetEvent: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 37: Line 37:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
 
[Ptr 09/23/2019]
{| border=1 style="border-spacing: 4px; border-collapse: collapse; border: 1px solid darkgrey;"
! style="width: 200px;" | purpose !! style="width: 100px;" | code
|-
| kResetEventID || 3
|-
| kOnObjPrefEventID || 4
|-
| kObjOnInitXProperties || 5
|-
| kOnDoubleClick || 7
|-
| kObjOnObjectUIButtonHit || 35
|-
| kObjOnAddState || 44
|}
</remark>
</remark>



Revision as of 21:41, 23 September 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

See the <a href=http://www.vectorlab.info/index.php?title=Events>VectorLab article</a> on object events.

FUNCTION GetEvent( ) :LONGINT;
def vs.GetEvent():
    return LONGINT

Parameters

Remarks

[Ptr 09/23/2019]

purpose code
kResetEventID 3
kOnObjPrefEventID 4
kObjOnInitXProperties 5
kOnDoubleClick 7
kObjOnObjectUIButtonHit 35
kObjOnAddState 44

Version

Availability: from All Versions

This is drop-in function.