VS:GetEntityMatrix: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the matrix of the plane for a planar object.

FUNCTION GetEntityMatrix(
VAR objectHandle :HANDLE;
VAR offsetX :REAL;
VAR offsetY :REAL;
VAR offsetZ :REAL;
VAR rotationXAngle :REAL;
VAR rotationYAngle :REAL;
VAR rotationZAngle :REAL) : BOOLEAN;
def vs.GetEntityMatrix(objectHandle):
    return (BOOLEAN, offset, rotationXAngle, rotationYAngle, rotationZAngle)

Parameters

objectHandle HANDLE The object for which the matrix of its plane is being obtained.
offsetX REAL The offset of the plane in current document units.
offsetY REAL The offset of the plane in current document units.
offsetZ REAL The offset of the plane in current document units.
rotationXAngle REAL The rotation of the plane about the X-axis in degrees.
rotationYAngle REAL The rotation of the plane about the Y-axis in degrees.
rotationZAngle REAL The rotation of the plane about the Z-axis in degrees.

Return Value

Returns true if the object passed is a planar object.

Version

Availability: from Vectorworks 2011