VS:GetEditInteger

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the numeric value from the specified INTEGER numeric edit field control.

FUNCTION GetEditInteger(
dialogID :LONGINT;
itemID :LONGINT;
VAR value :LONGINT) : BOOLEAN;
def vs.GetEditInteger(dialogID, itemID):
    return (BOOLEAN, value)

Parameters

dialogID LONGINT The index of the dialog layout containing the control.
itemID LONGINT The index of the control item.
value LONGINT The value contained in the field.

Return Value

A BOOLEAN value indicating the success of the operation.

Remarks

does math, returns false for any error in conversion

Version

Availability: from VectorWorks9.0