VS:GetEditInteger: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the numeric value from the specified INTEGER numeric edit field control.

FUNCTION GetEditInteger(
dialogID :LONGINT;
itemID :LONGINT;
VAR value :LONGINT) : BOOLEAN;
def vs.GetEditInteger(dialogID, itemID):
    return (BOOLEAN, value)

Parameters

dialogID LONGINT The index of the dialog layout containing the control.
itemID LONGINT The index of the control item.
value LONGINT The value contained in the field.

Return Value

A BOOLEAN value indicating the success of the operation.

Remarks

does math, returns false for any error in conversion

Version

Availability: from VectorWorks9.0