VS:GetDrawingSizeRect: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(No difference)

Revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the top left and bottom right coordinates of a rectangle surrounding the entire area of the document containing objects.

PROCEDURE GetDrawingSizeRect(
VAR p1X,p1Y :REAL;
VAR p2X,p2Y :REAL);
def vs.GetDrawingSizeRect():
    return (p1, p2)

Parameters

p1 REAL Returns top left coordinate of drawing rectangle.
p2 REAL Returns bottom right coordinate of drawing rectangle.

Return Value

Returns the size of the printable area of the drawing, in world units.

Example

VectorScript

PROCEDURE Example;
VAR
p1X, p1Y, p2X, p2Y :REAL;
BEGIN
GetDrawingSizeRect(p1X, p1Y, p2X, p2Y);
Message(p1X, ' ', p1Y, ' ', p2X, ' ', p2Y);
END;
RUN(Example);

Python


Version

Availability: from VectorWorks 8.0

See Also

VS Functions:

VS:SetDrawingRect

VS Functions: [[VS:SetDrawingRect]]