VS:GetDrawingSizeRect: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(add precisation)
Line 54: Line 54:
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
def Example():
p1, p2 = vs.GetDrawingSizeRect()
vs.Message(p1[0], ' ', p1[1], ' ', p2[0], ' ', p2[1])


Example()
</code>
</code>
</sample>
</sample>
-----------------------------------------------------------------------------------------------------------
<remark>
([[User:Orso.b.schmid|Orso]], 2014.08.19): The returned coordinates are (current units, page) the top-left, bottom-right coordinates of the printable page in the active layer. These coordinates can vary if the active layer is sheet or design layer. The newer routine  [[VS:SetDrawingRectN]] allows to pass a handle to a layer.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
VS Functions:
VS Functions:
[[VS:SetDrawingRect]]
* [[VS:SetDrawingRect]]
* [[VS:SetDrawingRectN]]
</seeAlso>
</seeAlso>



Revision as of 09:09, 19 August 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the top left and bottom right coordinates of a rectangle surrounding the entire area of the document containing objects.

PROCEDURE GetDrawingSizeRect(
VAR p1X,p1Y :REAL;
VAR p2X,p2Y :REAL);
def vs.GetDrawingSizeRect():
    return (p1, p2)

Parameters

p1 REAL Returns top left coordinate of drawing rectangle.
p2 REAL Returns bottom right coordinate of drawing rectangle.

Return Value

Returns the size of the printable area of the drawing, in world units.

Remarks

(Orso, 2014.08.19): The returned coordinates are (current units, page) the top-left, bottom-right coordinates of the printable page in the active layer. These coordinates can vary if the active layer is sheet or design layer. The newer routine VS:SetDrawingRectN allows to pass a handle to a layer.

Example

VectorScript

PROCEDURE Example;
VAR
p1X, p1Y, p2X, p2Y :REAL;
BEGIN
GetDrawingSizeRect(p1X, p1Y, p2X, p2Y);
Message(p1X, ' ', p1Y, ' ', p2X, ' ', p2Y);
END;
RUN(Example);

Python

def Example():
	p1, p2 = vs.GetDrawingSizeRect()
	vs.Message(p1[0], ' ', p1[1], ' ', p2[0], ' ', p2[1])

Example()

Version

Availability: from VectorWorks 8.0

See Also

VS Functions:

VS Functions:
  • [[VS:SetDrawingRect]]
  • [[VS:SetDrawingRectN]]