VS:GetDrawingArea: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 49: Line 49:
<seeAlso></seeAlso>
<seeAlso></seeAlso>


-----------------------------------------------------------------------------------------------------------
<version>
GetDrawingArea is obsolete as of VectorWorks0.0<P>





Latest revision as of 18:50, 7 September 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the drawing area of the active layer, as in Page Setup dialog. If Other is selected returns an empty string as outDrawingArea and true for outIsOther.If One Printer Page is Selected, returns empty string for outDrawingArea and true for outIsOnePrinterPage. Otherwise, returns the drawing area name (ISO A3, US ARCH A, etc.)

PROCEDURE GetDrawingArea(
VAR outDrawingArea :STRING;
VAR outIsOther :BOOLEAN;
VAR outIsOnePrintedPage :BOOLEAN);
def vs.GetDrawingArea():
    return (STRING, outDrawingArea, outIsOther, outIsOnePrintedPage)

Parameters

outDrawingArea STRING Returns the paper size name of the active layer, if it is found in the predefined paper sizes from DwgSizes-Universal.txt.
outIsOther BOOLEAN Returns true, if the paper size of the active layer is not one of the predefined sizes from DwgSizes-Universal.txt.
outIsOnePrintedPage BOOLEAN Returns true, if One Printer Page was selected in Page Setup dialog and the page area is the same as the selected from the printer page area.