VS:GetDialog

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Displays the specified custom dialog and brings it to the front of the dialog order.

Note: This procedure should NOT be a part of the dialog definition.

PROCEDURE GetDialog(
dialogID :INTEGER);
def vs.GetDialog(dialogID):
    return None

Parameters

dialogID INTEGER ID number of dialog to be displayed.

Example

VectorScript

PROCEDURE Example;
VAR
Done : BOOLEAN;
Stop : BOOLEAN;
BEGIN
Done:=False;
Stop:=FALSE;

GetDialog(1);
SetTitle('Dessert Toppings');
InsertChoice(4,0,'Basic');
InsertChoice(4,1,'Deluxe');
InsertChoice(4,2,'Mmm!Yummy!');
END;

RUN(Example);

Python


Version

Availability: from All Versions. Deprecated from VW 15+.