VS:GetDashStyleN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 25: Line 25:
swt
swt
BOOLEAN
BOOLEAN
scales with thickness


</line>
</line>
Line 30: Line 31:
numPairs
numPairs
INTEGER
INTEGER
count of used pairs


</line>
</line>

Latest revision as of 13:09, 19 April 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetDashStyleN searches for the pattern specified by the parameters. If it exists, then the negative value of the dash pattern's internal index is returned. If it does not exist, then it is added to the document and the negative value of the dash pattern's internal index is returned.

FUNCTION GetDashStyleN(
swt :BOOLEAN;
numPairs :INTEGER;
pair1 :REAL;
pair2 :REAL;
pair3 :REAL;
pair4 :REAL;
pair5 :REAL) : LONGINT;
def vs.GetDashStyleN(swt, numPairs, pair1, pair2, pair3, pair4, pair5):
    return LONGINT

Parameters

swt BOOLEAN scales with thickness
numPairs INTEGER count of used pairs
pair1 REAL
pair2 REAL
pair3 REAL
pair4 REAL
pair5 REAL

Remarks

Searches for the pattern specified by the parameters. If it exists, then the negative value of the dash pattern's internal index is returned. If it does not exist, then it is added to the document and the negative value of the dash pattern's internal index is returned.

Example

currLS:=GetDashStyleN;

Version

Availability: from Vectorworks 2019