VS:GetDashStyleIndex: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(expand and add remark)
(expand)
Line 69: Line 69:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[[User:Orso.b.schmid|Orso]], 2016.03.01:  The dash style index returned is relative to the dash style list, so it's not an index that can be used with [[VS:Index2Name]]. This routine seems to be exactly the same as [[VS:GetDashStyle]]: it also sets the found/created dash style to active.
[[User:Orso.b.schmid|Orso]], 2016.03.01:  The dash style index returned is relative to the dash style list, so it's not an index that can be used with [[VS:Index2Name]]. This routine seems to be the same as [[VS:GetDashStyle]] without setting the found/created dash style to active style.
<code lang="vs">
<code lang="vs">
indx := GetDashStyleIndex(swt, 2, 0.12, 0.03);  
indx := GetDashStyleIndex(TRUE, 1, 0.12, 0.03);  
{ returns the dash style index of 'ISO-02 Dashed' or creates a style in the document with these values }
{ returns the dash style index of 'ISO-02 Dashed' or creates a style in the document with these values }
</code>
</code>


Parameter swt defines whether the linestyle will be scaled with thickness, and parameter numPairs specifies the number of length pairs (2-10) defining the linestyle.  
Parameter swt defines whether the linestyle will be scaled with thickness, and parameter numPairs specifies the number of length pairs (2-10) defining the linestyle.
The linestyle is defined by up to five black/white length pairs, which are specified in parameters pair1 through pair5. The minimum length of any given black or white parameter is 1 point, or 1/72 of an inch, and the line specification must be in pairs.   
The linestyle is defined by up to five black/white length pairs, which are specified in parameters pair1 through pair5. The minimum length of any given black or white parameter is 1 point, or 1/72 of an inch, and the line specification must be in pairs.   
The Function will also set the document default line style.
The Function will also set the document default line style.

Revision as of 14:18, 1 March 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetDashStyleIndex searches for the pattern specified by the parameters. If it exists, then the linestyle index associated with the existing dash pattern is returned. If it does not exist, then it is added to the document and the linestyle index associated with the new dash pattern is returned.

FUNCTION GetDashStyleIndex(
swt :BOOLEAN;
numPairs :INTEGER;
pair1 :REAL;
pair2 :REAL;
pair3 :REAL;
pair4 :REAL;
pair5 :REAL) : INTEGER;
def vs.GetDashStyleIndex(swt, numPairs, pair1, pair2, pair3, pair4, pair5):
    return INTEGER

Parameters

swt BOOLEAN scales with thickness
numPairs INTEGER count of used pairs
pair1 REAL values in pt (1/72 inches)
pair2 REAL values in pt (1/72 inches) or empty
pair3 REAL values in pt (1/72 inches) or empty
pair4 REAL values in pt (1/72 inches) or empty
pair5 REAL values in pt (1/72 inches) or empty

Remarks

Orso, 2016.03.01: The dash style index returned is relative to the dash style list, so it's not an index that can be used with VS:Index2Name. This routine seems to be the same as VS:GetDashStyle without setting the found/created dash style to active style.

indx := GetDashStyleIndex(TRUE, 1, 0.12, 0.03); 
{ returns the dash style index of 'ISO-02 Dashed' or creates a style in the document with these values }

Parameter swt defines whether the linestyle will be scaled with thickness, and parameter numPairs specifies the number of length pairs (2-10) defining the linestyle. The linestyle is defined by up to five black/white length pairs, which are specified in parameters pair1 through pair5. The minimum length of any given black or white parameter is 1 point, or 1/72 of an inch, and the line specification must be in pairs. The Function will also set the document default line style.

Version

Availability: from Vectorworks 2010