VS:GetDashDataValPairAt/ja

From Vectorworks Developer
Revision as of 01:06, 13 January 2015 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

指定した破線の種類の破線データを返します。 破線データは破線/間隔のペアです。 破線の種類や破線データがない場合はFalseを返します。 破線の種類では破線/間隔のペアを5つまで指定できます。

FUNCTION GetDashDataValPairAt(
dashStyleIndex :INTEGER;
dataIndex :INTEGER;
VAR dash :REAL;
VAR gap :REAL) : BOOLEAN;
def vs.GetDashDataValPairAt(dashStyleIndex, dataIndex):
    return (BOOLEAN, dash, gap)

Parameters

dashStyleIndex INTEGER 破線の種類のインデックス
dataIndex INTEGER 破線データのインデックス
dash REAL 破線の長さ
gap REAL 間隔の長さ

Example

PROCEDURE Example;
VAR
n, numPairs, dashIndex : INTEGER;
scaleWThick  :BOOLEAN;
arrayDashDat : ARRAY[1..5] OF POINT;
x,y : REAL;

BEGIN

dashIndex := GetDashStyleIndex(TRUE, 2, 0.12, 0.18, 0.03, 0.07);

numPairs := GetNumDashDataPairs(dashIndex,scaleWThick);

FOR n := 1 TO numPairs DO BEGIN
 IF (GetDashDataValPairAt(dashIndex, n , x, y)) THEN BEGIN
   arrayDashDat[n].x := x ;
   arrayDashDat[n].y := y ;
 END; 
END;

END;
RUN(Example);

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetNumDashDataPairs | VS:GetDashStyleIndex

VS Functions:

[[VS:GetNumDashDataPairs]]

| [[VS:GetDashStyleIndex]]