VS:GetDLComponentPenStyles

From Vectorworks Developer
Revision as of 21:56, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the left and right side pen styles of the component at index in the Double Line Preferences.

FUNCTION GetDLComponentPenStyles(
index :INTEGER;
VAR penStyleLeft :INTEGER;
VAR penStyleRight :INTEGER) : BOOLEAN;
def vs.GetDLComponentPenStyles(index):
    return (BOOLEAN, penStyleLeft, penStyleRight)

Parameters

index INTEGER The index of the component.
penStyleLeft INTEGER Returns the pen style of the component's left line. Positive values for patters, negative values for dash styles.
penStyleRight INTEGER Returns the pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Remarks

CJG 6-27-06

Version

Availability: from VectorWorks12.5

See Also

VS Functions:

VS:SetDLComponentPenStyles

VS Functions: [[VS:SetDLComponentPenStyles]]