VS:GetDLComponentPenColors

From Vectorworks Developer
Revision as of 21:56, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the fore and back colors of the left and right side pens of the component at index in the Double Line Preferences.

FUNCTION GetDLComponentPenColors(
index :INTEGER;
VAR leftPenForeColor :INTEGER;
VAR leftPenBackColor :INTEGER;
VAR rightPenForeColor :INTEGER;
VAR rightPenBackColor :INTEGER) : BOOLEAN;
def vs.GetDLComponentPenColors(index):
    return (BOOLEAN, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor)

Parameters

index INTEGER The index of the component.
leftPenForeColor INTEGER Returns the fore color of the left pen.
leftPenBackColor INTEGER Returns the back color of the left pen.
rightPenForeColor INTEGER Returns the fore color of the right pen.
rightPenBackColor INTEGER Resturns the back color of the right pen.

Remarks

CJG 3-23-07

Version

Availability: from VectorWorks13.0

See Also

VS Functions:

VS:SetDLComponentPenColors

VS Functions: [[VS:SetDLComponentPenColors]]