VS:GetCustomObjectProfileGroup

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a handle to the profile group of a path custom object.

A path object has two "containers" for storing subordinate objects: the path, and the profile. As an example, if a path object is going to do an extrude along path, it will store the path in the path container, and the shape to be extruded in the profile container. The code within the object will then supply the handles to the path and the profile to the CreateExtrudeAlongPath call.

FUNCTION GetCustomObjectProfileGroup(
objectHand :HANDLE) : HANDLE;
def vs.GetCustomObjectProfileGroup(objectHand):
    return HANDLE

Parameters

objectHand HANDLE Handle to path custom object.

Return Value

Returns a HANDLE to the profile group.

Version

Availability: from VectorWorks8.5

See Also

VS Functions:

VS:SetCustomObjectProfileGroup

VS Functions: [[VS:SetCustomObjectProfileGroup]]