VS:GetCurrentMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(One intermediate revision by one other user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns the current application protection mode.
Returns the current application protection mode as bitwise OR.  Each bit is used as a flag to indicate what is allowable in a 16 bit byte.


Return values:
Return values:
0 - Mode Not Set
0 - Mode Not Set
1 - Full Mode
1 - Full Mode
2 - Demo Mode
2 - Demo Mode
4 - Education Mode
4 - Education Mode
8 - Student Mode
8 - Student Mode
16 - Viewer Mode
16 - Viewer Mode
32 - Unlicensed Mode
32 - Unlicensed Mode
64 - Banner Mode
64 - Banner Mode
128 - Watermark New Files Mode
128 - Watermark New Files Mode
256 - Print Watermark Mode
256 - Print Watermark Mode
512 - Save Educational File Format Mode
512 - Save Educational File Format Mode
1024 - Open Educational File Format Mode
1024 - Open Educational File Format Mode
2048 - Vector Script Export Mode
2048 - Vector Script Export Mode
4096 - Beta Serial Number Mode</desc>
 
4096 - Beta Serial Number Mode
 
 
456 in binary is 0000111001000.  (Read from the right to left)
 
8 Student Mode
 
64 Banner Mode
 
128 Watermark New Files Mode
 
256 Print Watermark Mode
 
256+128+64+8 = 456
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 15:27, 31 March 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the current application protection mode as bitwise OR. Each bit is used as a flag to indicate what is allowable in a 16 bit byte.

Return values:

0 - Mode Not Set

1 - Full Mode

2 - Demo Mode

4 - Education Mode

8 - Student Mode

16 - Viewer Mode

32 - Unlicensed Mode

64 - Banner Mode

128 - Watermark New Files Mode

256 - Print Watermark Mode

512 - Save Educational File Format Mode

1024 - Open Educational File Format Mode

2048 - Vector Script Export Mode

4096 - Beta Serial Number Mode


456 in binary is 0000111001000. (Read from the right to left)

8 Student Mode

64 Banner Mode

128 Watermark New Files Mode

256 Print Watermark Mode

256+128+64+8 = 456

FUNCTION GetCurrentMode : INTEGER;
def vs.GetCurrentMode():
    return INTEGER

Version

Availability: from VectorWorks10.0