VS:GetCurrentLocalization

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the Vectorworks language in the ISO 639-3 draft standard Language ID and sublanguage is unused and will be the empty string reserved for future use for a regional dialect.


Currently this will always return the same language for a given installation of Vectorworks.

PROCEDURE GetCurrentLocalization(
VAR language :STRING;
VAR subLanguage :STRING);
def vs.GetCurrentLocalization():
    return (language, subLanguage)

Parameters

language STRING Output parameter. Returns language in ISO 639-3 draft standard Language ID.
subLanguage STRING Output parameter. Unused. Returns empty string.

Version

Availability: from Vectorworks 2010