VS:GetCoreWallComponent: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetCoreWallComponent(object:HANDLE) : INTEGER;
FUNCTION GetCoreWallComponent(obj:HANDLE) : INTEGER;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetCoreWallComponent(object):
def vs.GetCoreWallComponent(obj):
     return INTEGER
     return INTEGER
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.

Latest revision as of 19:54, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the core wall component of an object.

FUNCTION GetCoreWallComponent(
obj :HANDLE) : INTEGER;
def vs.GetCoreWallComponent(obj):
    return INTEGER

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.

Return Value

The index of the core wall component. If it is 0, there is no core wall component.

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:SetCoreWallComponent

VS Functions: [[VS:SetCoreWallComponent]]