VS:GetControlData

From Vectorworks Developer
Revision as of 21:05, 27 February 2014 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns information about the specified extended control item.

PROCEDURE GetControlData(
dialogID :LONGINT;
itemID :LONGINT;
VAR data :LONGINT);
def vs.GetControlData(dialogID, itemID):
    return data

Parameters

dialogID LONGINT Index of dialog layout containing the control item.
itemID LONGINT Index of the control item.
data LONGINT Current setting of the control.

Remarks

This function supports the following control types:

  • color button -- the data is a 32-bit number of the red/green/blue components represented as 8-bit numbers
  • slider -- the data is the slider position

Version

Availability: from VectorWorks8.5

See Also

VS:SetControlData

[[VS:SetControlData]]