VS:GetComponentWidth

From Vectorworks Developer
Revision as of 16:43, 4 October 2010 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the width of a component in an object.

FUNCTION GetComponentWidth(
object :HANDLE;
componentIndex :INTEGER;
VAR width :REAL) : BOOLEAN;
def vs.GetComponentWidth(object, componentIndex):
    return (BOOLEAN, width)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
width REAL Returns the width of the component.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:SetComponentWidth

VS Functions: [[VS:SetComponentWidth]]