VS:GetComponentWidth

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the width of a component in an object.

FUNCTION GetComponentWidth(
object :HANDLE;
componentIndex :INTEGER;
VAR width :REAL) : BOOLEAN;
def vs.GetComponentWidth(object, componentIndex):
    return (BOOLEAN, width)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
width REAL Returns the width of the component.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:SetComponentWidth

VS Functions: [[VS:SetComponentWidth]]