VS:GetComponentWidth: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentWidth(object:HANDLE; componentIndex:INTEGER; VAR width:REAL) : BOOLEAN;
FUNCTION GetComponentWidth(obj:HANDLE; componentIndex:INTEGER; VAR width:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentWidth(object, componentIndex):
def vs.GetComponentWidth(obj, componentIndex):
     return (BOOLEAN, width)
     return (BOOLEAN, width)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 54: Line 54:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 19:53, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the width of a component in an object.

FUNCTION GetComponentWidth(
obj :HANDLE;
componentIndex :INTEGER;
VAR width :REAL) : BOOLEAN;
def vs.GetComponentWidth(obj, componentIndex):
    return (BOOLEAN, width)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
width REAL Returns the width of the component.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:SetComponentWidth

VS Functions: [[VS:SetComponentWidth]]