VS:GetComponentWallTopOffset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentWallTopOffset(object:HANDLE; componentIndex:INTEGER; VAR offsetFromWallTop:REAL) : BOOLEAN;
FUNCTION GetComponentWallTopOffset(obj:HANDLE; componentIndex:INTEGER; VAR offsetFromWallTop:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentWallTopOffset(object, componentIndex):
def vs.GetComponentWallTopOffset(obj, componentIndex):
     return (BOOLEAN, offsetFromWallTop)
     return (BOOLEAN, offsetFromWallTop)
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.

Latest revision as of 19:53, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the offset from wall top of a component in an object.

FUNCTION GetComponentWallTopOffset(
obj :HANDLE;
componentIndex :INTEGER;
VAR offsetFromWallTop :REAL) : BOOLEAN;
def vs.GetComponentWallTopOffset(obj, componentIndex):
    return (BOOLEAN, offsetFromWallTop)

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
offsetFromWallTop REAL Returns the offset from wall top of the component.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentWallTopOffset

VS Functions: [[VS:SetComponentWallTopOffset]]