VS:GetComponentWallBottomOffset

From Vectorworks Developer
Revision as of 19:52, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the offset from wall bottom of a component in an object.

FUNCTION GetComponentWallBottomOffset(
obj :HANDLE;
componentIndex :INTEGER;
VAR offsetFromWallBottom :REAL) : BOOLEAN;
def vs.GetComponentWallBottomOffset(obj, componentIndex):
    return (BOOLEAN, offsetFromWallBottom)

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
offsetFromWallBottom REAL Returns the offset from wall bottom of the component.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentWallBottomOffset

VS Functions: [[VS:SetComponentWallBottomOffset]]