VS:GetComponentWallBottomOffset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentWallBottomOffset(object:HANDLE; componentIndex:INTEGER; VAR offsetFromWallBottom:REAL) : BOOLEAN;
FUNCTION GetComponentWallBottomOffset(obj:HANDLE; componentIndex:INTEGER; VAR offsetFromWallBottom:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentWallBottomOffset(object, componentIndex):
def vs.GetComponentWallBottomOffset(obj, componentIndex):
     return (BOOLEAN, offsetFromWallBottom)
     return (BOOLEAN, offsetFromWallBottom)
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.

Latest revision as of 19:52, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the offset from wall bottom of a component in an object.

FUNCTION GetComponentWallBottomOffset(
obj :HANDLE;
componentIndex :INTEGER;
VAR offsetFromWallBottom :REAL) : BOOLEAN;
def vs.GetComponentWallBottomOffset(obj, componentIndex):
    return (BOOLEAN, offsetFromWallBottom)

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
offsetFromWallBottom REAL Returns the offset from wall bottom of the component.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentWallBottomOffset

VS Functions: [[VS:SetComponentWallBottomOffset]]