VS:GetComponentUsePenClassAttr

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class attributes flags of the pens of a component in an object.

FUNCTION GetComponentUsePenClassAttr(
object :HANDLE;
componentIndex :INTEGER;
VAR useLeftPenClassAttributes :BOOLEAN;
VAR useRightPenClassAttributes :BOOLEAN) : BOOLEAN;
def vs.GetComponentUsePenClassAttr(object, componentIndex):
    return (BOOLEAN, useLeftPenClassAttributes, useRightPenClassAttributes)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
useLeftPenClassAttributes BOOLEAN Returns whether or not the component is using class attributes for its left pen.
useRightPenClassAttributes BOOLEAN Returns whether or not the component is using class attributes for its right pen.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentUsePenClassAttr

VS Functions: [[VS:SetComponentUsePenClassAttr]]