VS:GetComponentUsePenClassAttr

From Vectorworks Developer
Revision as of 19:52, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class attributes flags of the pens of a component in an object.

FUNCTION GetComponentUsePenClassAttr(
obj :HANDLE;
componentIndex :INTEGER;
VAR useLeftPenClassAttributes :BOOLEAN;
VAR useRightPenClassAttributes :BOOLEAN) : BOOLEAN;
def vs.GetComponentUsePenClassAttr(obj, componentIndex):
    return (BOOLEAN, useLeftPenClassAttributes, useRightPenClassAttributes)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
useLeftPenClassAttributes BOOLEAN Returns whether or not the component is using class attributes for its left pen.
useRightPenClassAttributes BOOLEAN Returns whether or not the component is using class attributes for its right pen.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentUsePenClassAttr

VS Functions: [[VS:SetComponentUsePenClassAttr]]