VS:GetComponentUsePenClassAttr: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentUsePenClassAttr(object:HANDLE; componentIndex:INTEGER; VAR useLeftPenClassAttributes:BOOLEAN; VAR useRightPenClassAttributes:BOOLEAN) : BOOLEAN;
FUNCTION GetComponentUsePenClassAttr(obj:HANDLE; componentIndex:INTEGER; VAR useLeftPenClassAttributes:BOOLEAN; VAR useRightPenClassAttributes:BOOLEAN) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentUsePenClassAttr(object, componentIndex):
def vs.GetComponentUsePenClassAttr(obj, componentIndex):
     return (BOOLEAN, useLeftPenClassAttributes, useRightPenClassAttributes)
     return (BOOLEAN, useLeftPenClassAttributes, useRightPenClassAttributes)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 19:52, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class attributes flags of the pens of a component in an object.

FUNCTION GetComponentUsePenClassAttr(
obj :HANDLE;
componentIndex :INTEGER;
VAR useLeftPenClassAttributes :BOOLEAN;
VAR useRightPenClassAttributes :BOOLEAN) : BOOLEAN;
def vs.GetComponentUsePenClassAttr(obj, componentIndex):
    return (BOOLEAN, useLeftPenClassAttributes, useRightPenClassAttributes)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
useLeftPenClassAttributes BOOLEAN Returns whether or not the component is using class attributes for its left pen.
useRightPenClassAttributes BOOLEAN Returns whether or not the component is using class attributes for its right pen.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentUsePenClassAttr

VS Functions: [[VS:SetComponentUsePenClassAttr]]