VS:GetComponentUseFillClassAttr

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use fill class attributes flag of a component in an object.

FUNCTION GetComponentUseFillClassAttr(
object :HANDLE;
componentIndex :INTEGER;
VAR useFillClassAttributes :BOOLEAN) : BOOLEAN;
def vs.GetComponentUseFillClassAttr(object, componentIndex):
    return (BOOLEAN, useFillClassAttributes)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
useFillClassAttributes BOOLEAN Returns whether or not the component is using class attributes for its fill.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentUseFillClassAttr

VS Functions: [[VS:SetComponentUseFillClassAttr]]