VS:GetComponentUseFillClassAttr: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
(One intermediate revision by one other user not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentUseFillClassAttr(object:HANDLE; componentIndex:INTEGER; VAR useFillClassAttributes:BOOLEAN) : BOOLEAN;
FUNCTION GetComponentUseFillClassAttr(obj:HANDLE; componentIndex:INTEGER; VAR useFillClassAttributes:BOOLEAN) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentUseFillClassAttr(object, componentIndex):
def vs.GetComponentUseFillClassAttr(obj, componentIndex):
     return (BOOLEAN, useFillClassAttributes)
     return (BOOLEAN, useFillClassAttributes)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 19:51, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use fill class attributes flag of a component in an object.

FUNCTION GetComponentUseFillClassAttr(
obj :HANDLE;
componentIndex :INTEGER;
VAR useFillClassAttributes :BOOLEAN) : BOOLEAN;
def vs.GetComponentUseFillClassAttr(obj, componentIndex):
    return (BOOLEAN, useFillClassAttributes)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
useFillClassAttributes BOOLEAN Returns whether or not the component is using class attributes for its fill.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentUseFillClassAttr

VS Functions: [[VS:SetComponentUseFillClassAttr]]