VS:GetComponentTexture/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision: 2014J VS Reference G-1)
No edit summary
Line 1: Line 1:
{{LocationMain|category=LocationVS/ja|specific=}}
{{LocationMain|category=LocationVS/ja|specific=}}
__TOC__
__TOC__
Line 24: Line 25:
object
object
HANDLE
HANDLE
オブジェクト。壁、円弧壁、スラブ、壁スタイル、スラブスタイル、壁設定もしくは、スラブ設定。
オブジェクトのハンドル(壁、円弧壁、スラブ、屋根、壁スタイル、スラブスタイル、屋根スタイル、壁設定、スラブ設定もしくは、屋根設定)
</line>
</line>
<line>
<line>
componentIndex
componentIndex
INTEGER
INTEGER
構成要素のインデックス
構成要素の番号
</line>
</line>
<line>
<line>
Line 47: Line 48:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
VS Functions:
関連関数:
[[VS:SetComponentTexture]]  
[[VS:SetComponentTexture]]  
</seeAlso>
</seeAlso>
Line 53: Line 54:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from Vectorworks 2011
利用可能バージョン: Vectorworks 2011


</version>
</version>

Revision as of 12:28, 14 January 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

図形の構成要素のテクスチャを取得します。

FUNCTION GetComponentTexture(
object :HANDLE;
componentIndex :INTEGER;
VAR texture :LONGINT) : BOOLEAN;
def vs.GetComponentTexture(object, componentIndex):
    return (BOOLEAN, texture)

Parameters

object HANDLE オブジェクトのハンドル(壁、円弧壁、スラブ、屋根、壁スタイル、スラブスタイル、屋根スタイル、壁設定、スラブ設定もしくは、屋根設定)
componentIndex INTEGER 構成要素の番号
texture LONGINT テクスチャの参照番号を返します。テクスチャがない場合は0、クラステクスチャの場合は-1。

Version

利用可能バージョン: Vectorworks 2011

See Also

関連関数:

VS:SetComponentTexture

関連関数: [[VS:SetComponentTexture]]