VS:GetComponentTexture

From Vectorworks Developer
Revision as of 19:51, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the texture of a component in an object.

FUNCTION GetComponentTexture(
obj :HANDLE;
componentIndex :INTEGER;
VAR texture :LONGINT) : BOOLEAN;
def vs.GetComponentTexture(obj, componentIndex):
    return (BOOLEAN, texture)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
texture LONGINT Returns the ref number of the texture. 0 for no texture. -1 for class texture.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentTexture

VS Functions: [[VS:SetComponentTexture]]