VS:GetComponentTexture: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentTexture(object:HANDLE; componentIndex:INTEGER; VAR texture:LONGINT) : BOOLEAN;
FUNCTION GetComponentTexture(obj:HANDLE; componentIndex:INTEGER; VAR texture:LONGINT) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentTexture(object, componentIndex):
def vs.GetComponentTexture(obj, componentIndex):
     return (BOOLEAN, texture)
     return (BOOLEAN, texture)
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 19:51, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the texture of a component in an object.

FUNCTION GetComponentTexture(
obj :HANDLE;
componentIndex :INTEGER;
VAR texture :LONGINT) : BOOLEAN;
def vs.GetComponentTexture(obj, componentIndex):
    return (BOOLEAN, texture)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
texture LONGINT Returns the ref number of the texture. 0 for no texture. -1 for class texture.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentTexture

VS Functions: [[VS:SetComponentTexture]]