VS:GetComponentRect

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the bounding rect coordinates of the specified Layout Manager component.

FUNCTION GetComponentRect(
nDialogID :LONGINT;
nComponentID :LONGINT;
VAR nLeft :INTEGER;
VAR nTop :INTEGER;
VAR nRight :INTEGER;
VAR nBottom :INTEGER) : BOOLEAN;
def vs.GetComponentRect(nDialogID, nComponentID):
    return (BOOLEAN, nLeft, nTop, nRight, nBottom)

Parameters

nDialogID LONGINT
nComponentID LONGINT
nLeft INTEGER
nTop INTEGER
nRight INTEGER
nBottom INTEGER

Version

Availability: from VectorWorks13.0