VS:GetComponentRect

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the bounding rect coordinates of the specified Layout Manager component.

FUNCTION GetComponentRect(
nDialogID :LONGINT;
nComponentID :LONGINT;
VAR nLeft :INTEGER;
VAR nTop :INTEGER;
VAR nRight :INTEGER;
VAR nBottom :INTEGER) : BOOLEAN;
def vs.GetComponentRect(nDialogID, nComponentID):
    return (BOOLEAN, nLeft, nTop, nRight, nBottom)

Parameters

nDialogID LONGINT
nComponentID LONGINT
nLeft INTEGER
nTop INTEGER
nRight INTEGER
nBottom INTEGER

Version

Availability: from VectorWorks13.0