VS:GetComponentPenWeights

From Vectorworks Developer
Revision as of 19:50, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the pen weights of the left and right sides of a component in an object.

FUNCTION GetComponentPenWeights(
obj :HANDLE;
componentIndex :INTEGER;
VAR leftPenWeight :INTEGER;
VAR rightPenWeight :INTEGER) : BOOLEAN;
def vs.GetComponentPenWeights(obj, componentIndex):
    return (BOOLEAN, leftPenWeight, rightPenWeight)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenWeight INTEGER Returns the pen weight of the component's left line.
rightPenWeight INTEGER Returns the pen weight of the component's right line.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:SetComponentPenWeights

VS Functions: [[VS:SetComponentPenWeights]]