VS:GetComponentPenWeights: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the pen weights of the left and right sides of a component in an object.

FUNCTION GetComponentPenWeights(
object :HANDLE;
componentIndex :INTEGER;
VAR leftPenWeight :INTEGER;
VAR rightPenWeight :INTEGER) : BOOLEAN;
def vs.GetComponentPenWeights(object, componentIndex):
    return (BOOLEAN, leftPenWeight, rightPenWeight)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenWeight INTEGER Returns the pen weight of the component's left line.
rightPenWeight INTEGER Returns the pen weight of the component's right line.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:SetComponentPenWeights

VS Functions: [[VS:SetComponentPenWeights]]