VS:GetComponentPenWeights: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentPenWeights(object:HANDLE; componentIndex:INTEGER; VAR leftPenWeight:INTEGER; VAR rightPenWeight:INTEGER) : BOOLEAN;
FUNCTION GetComponentPenWeights(obj:HANDLE; componentIndex:INTEGER; VAR leftPenWeight:INTEGER; VAR rightPenWeight:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentPenWeights(object, componentIndex):
def vs.GetComponentPenWeights(obj, componentIndex):
     return (BOOLEAN, leftPenWeight, rightPenWeight)
     return (BOOLEAN, leftPenWeight, rightPenWeight)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 59: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 19:50, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the pen weights of the left and right sides of a component in an object.

FUNCTION GetComponentPenWeights(
obj :HANDLE;
componentIndex :INTEGER;
VAR leftPenWeight :INTEGER;
VAR rightPenWeight :INTEGER) : BOOLEAN;
def vs.GetComponentPenWeights(obj, componentIndex):
    return (BOOLEAN, leftPenWeight, rightPenWeight)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenWeight INTEGER Returns the pen weight of the component's left line.
rightPenWeight INTEGER Returns the pen weight of the component's right line.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:SetComponentPenWeights

VS Functions: [[VS:SetComponentPenWeights]]