VS:GetComponentPenStyles

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the left and right side pen styles of a component in an object.

FUNCTION GetComponentPenStyles(
obj :HANDLE;
componentIndex :INTEGER;
VAR leftPenStyle :INTEGER;
VAR rightPenStyle :INTEGER) : BOOLEAN;
def vs.GetComponentPenStyles(obj, componentIndex):
    return (BOOLEAN, leftPenStyle, rightPenStyle)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenStyle INTEGER Returns the pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle INTEGER Returns the pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Remarks

_c_, 2016.02.04: This doesn't support Line Types: the values returned are faulty. Use VS:GetCompPenStylesN

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:SetComponentPenStyles

VS Functions: [[VS:SetComponentPenStyles]]