VS:GetComponentPenStyles: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the left and right side pen styles of a component in an object.

FUNCTION GetComponentPenStyles(
object :HANDLE;
componentIndex :INTEGER;
VAR leftPenStyle :INTEGER;
VAR rightPenStyle :INTEGER) : BOOLEAN;
def vs.GetComponentPenStyles(object, componentIndex):
    return (BOOLEAN, leftPenStyle, rightPenStyle)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenStyle INTEGER Returns the pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle INTEGER Returns the pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:SetComponentPenStyles

VS Functions: [[VS:SetComponentPenStyles]]