VS:GetComponentPenStyles: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(fix routine name)
(3 intermediate revisions by 2 users not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentPenStyles(object:HANDLE; componentIndex:INTEGER; VAR leftPenStyle:INTEGER; VAR rightPenStyle:INTEGER) : BOOLEAN;
FUNCTION GetComponentPenStyles(obj:HANDLE; componentIndex:INTEGER; VAR leftPenStyle:INTEGER; VAR rightPenStyle:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentPenStyles(object, componentIndex):
def vs.GetComponentPenStyles(obj, componentIndex):
     return (BOOLEAN, leftPenStyle, rightPenStyle)
     return (BOOLEAN, leftPenStyle, rightPenStyle)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 46: Line 46:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>([[User:Orso.b.schmid|Orso]], 2016.02.04): This doesn't support Line Types: the values returned are faulty. Use [[VS:GetCompPenStylesN]]
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 59: Line 60:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Revision as of 07:46, 5 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the left and right side pen styles of a component in an object.

FUNCTION GetComponentPenStyles(
obj :HANDLE;
componentIndex :INTEGER;
VAR leftPenStyle :INTEGER;
VAR rightPenStyle :INTEGER) : BOOLEAN;
def vs.GetComponentPenStyles(obj, componentIndex):
    return (BOOLEAN, leftPenStyle, rightPenStyle)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenStyle INTEGER Returns the pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle INTEGER Returns the pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Remarks

(Orso, 2016.02.04): This doesn't support Line Types: the values returned are faulty. Use VS:GetCompPenStylesN

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:SetComponentPenStyles

VS Functions: [[VS:SetComponentPenStyles]]