VS:GetComponentPenColors: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentPenColors(object:HANDLE; componentIndex:INTEGER; VAR leftPenForeColor:INTEGER; VAR leftPenBackColor:INTEGER; VAR rightPenForeColor:INTEGER; VAR rightPenBackColor:INTEGER) : BOOLEAN;
FUNCTION GetComponentPenColors(obj:HANDLE; componentIndex:INTEGER; VAR leftPenForeColor:INTEGER; VAR leftPenBackColor:INTEGER; VAR rightPenForeColor:INTEGER; VAR rightPenBackColor:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentPenColors(object, componentIndex):
def vs.GetComponentPenColors(obj, componentIndex):
     return (BOOLEAN, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor)
     return (BOOLEAN, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 19:50, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the colors of the pens of a component in an object.

FUNCTION GetComponentPenColors(
obj :HANDLE;
componentIndex :INTEGER;
VAR leftPenForeColor :INTEGER;
VAR leftPenBackColor :INTEGER;
VAR rightPenForeColor :INTEGER;
VAR rightPenBackColor :INTEGER) : BOOLEAN;
def vs.GetComponentPenColors(obj, componentIndex):
    return (BOOLEAN, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenForeColor INTEGER Returns the fore color of the left pen.
leftPenBackColor INTEGER Returns the back color of the left pen.
rightPenForeColor INTEGER Returns the fore color of the right pen.
rightPenBackColor INTEGER Returns the back color of the right pen.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentPenColors

VS Functions: [[VS:SetComponentPenColors]]